Common Support Questions

1. MySQL: Common MySQL connection problems and how to fix them
2. MySQL: MySQL connection only works from local machine - Enable MySQL Remote Access
3. MySQL: MySQL keeps dropping the connection.
4. MySQL: Error when using the DELIMITER statement in MySQL
5. MySQL: cannot convert value '0000-00-00 00:00:00' from Column x to TimeStamp where x is the column number of the DATETIME column
6. MySQL: How to connect to MySQL versions older than 4.x, such as MySQL 3
7. MySQL: How to connect to the Mac MAMP MySQL database / Connecting to local MySQL server through socket /tmp/mysql.sock
8. MySQL: How to Connect Using different Character Sets or Character Encodings such as UTF-8
9. MySQL, PostgreSQL, SQL Server: Unable to make a connection to hosting provider database (MySQL, PostgreSQL, MS SQL Server)
10. PostgreSQL: PostgreSQL connection only works from local machine
11. PostgreSQL: How to connect to PostgreSQL over SSL using self signed certificate.
12. DB2: How to avoid table and row locking in DB2.
13. DB2: Information for connecting to DB2 on the mainframe (z/OS).
14. DB2: Connecting to DB2 on iSeries / AS400.
15. Oracle: When attempting to connect to Oracle, the following error is thrown:
Class oracle/sql/converter/CharacterConverters violates loader constraints.
16. Oracle: OCI Error - java.lang.UnsatisfiedLinkError: no ocijdbc10 in java.library.path
17. Oracle: The error, java.sql.SQLException: Stream has already been closed, is thrown when querying an Oracle table with long or long raw columns.
18.SQL Server: How to call a SQL Server DTS package.
19.SQL Server: How to Connect to MS SQL Server from a Mac.
20. SQL Server: The following error is received when connecting to SQL Server from a Mac:
Single-Sign-On is only supported on Windows. Please specify a user name.
21. SQL Server: SQL Server login failure state codes
22. SQL Server: How to use the GO SQL statement separator in RazorSQL for MS SQL Server
23. SQL Server: How to connect to SQL Server named instances
24. SQL Server / SQL Azure: Connecting to SQL Azure or SQL Server in the Cloud
25. SQL Server: Connection to SSL Enabled SQL Server / SQL Azure Hangs
26. SQL Server: Unable to connect to SQL Server Express
27. SQL Server / Sybase / SQL Anywhere: QUOTED_IDENTIFIER settings
28. SQL Server / Sybase: How to view multiple results sets for a query such as sp_help.
29. Sybase: How to resolve Sybase transaction log errors
30. DBASE: Information on connecting to DBASE
31. Netezza: Does RazorSQL support Netezza
32. Pervasive: Does RazorSQL support Pervasive
33. Paradox: Information on connecting to Paradox
34. Derby: Another instance of Derby may have already booted the database
35. Derby: Database has an incompatible format with the current version of the software
36. HSQLDB / HyperSQL: User not found
37. Cassandra: Cassandra SQL Syntax Guide
38. DynamoDB: DynamoDB SQL Support
39. MongoDB: MongoDB Syntax Guide
40. SSH Tunnel: How to Configure SSH Tunnels
41. Ubuntu: How to add RazorSQL to the Ubuntu menu launcher
42. Ubuntu: Graphics are flickering in Ubuntu
43. RazorSQL: Are administrator privileges required for installing RazorSQL on Windows machines?
44. RazorSQL: RazorSQL Performance Tuning Guide
45. RazorSQL: How to increase maximum memory settings for RazorSQL.
46. RazorSQL: How to save a query using RazorSQL
47. RazorSQL: How to launch RazorSQL in 64-bit mode on Mac OS X
48. RazorSQL: How to launch RazorSQL in read-only mode (Windows only)
49. RazorSQL: How to launch RazorSQL without accelerated graphics

 

Are administrator privileges required for installing RazorSQL on Windows machines?

Administrator privileges are not required to install RazorSQL. However, the default setting for the Windows installer is to install RazorSQL in the Program Files directory, which is probably not writeable for your logon id if you do not have administrator privileges. There are two ways to get around this: 1. The easiest is to download the latest razorsql<version>_windows.zip file from http://www.razorsql.com/download.html to your desktop. Then extract the zip file and navigate to the razorsql<version> directory and launch razorsql.exe or razorsql.bat. 2. The second way is to launch the razorsql<version>_setup.exe Windows installer and when given the choice as to where to install RazorSQL, be sure to change the directory from the Program Files directory to a directory you have write access to such as your desktop.

How to increase maximum memory settings for RazorSQL.

For newer versions of RazorSQL, RazorSQL ships with "himem" files that can be used to launch RazorSQL with higher memory settings. Listed below are instructions for how to launch RazorSQL with these files: Windows: On Windows, RazorSQL ships with a file called razorsql_himem.exe. Launching RazorSQL with this file quadruples the max memory limits of the normal razorsql.exe file. To launch RazorSQL with the higher memory settings, either launch RazorSQL by double-clicking the following file: <razorsql_install_dir>\razorsql_himem.exe or rename the existing razorsql.exe file to another name and rename the razorsql_himem.exe file to razorsql.exe. Mac OS X: Newer versions of RazorSQL have an "Adjust Memory Settings" option in the Help menu. Use this option to increase RazorSQL's memory settings. For older versions, RazorSQL ships with a custom Info.plist file on Mac OS X that contains higher memory settings. To launch RazorSQL with the higher memory settings, navigate to the following directory: /Applications/RazorSQL.app/Contents To get to this directory, right-click on the RazorSQL.app file and select "View Package Contents". Then open the "Contents" directory. rename the existing Info.plist file to something like Info.plist.old rename the Info.plist_himem file to Info.plist Relaunch RazorSQL and RazorSQL will now use increased memory settings. Linux: RazorSQL ships with a custom shell script launcher called razorsql_himem.sh. Instead of launching RazorSQL with the razorsql.sh script, use the razorsql_himem.sh script to launch RazorSQL. The following instructions contain information on how to change RazorSQL memory settings for older versions of RazorSQL: For Windows machines, the max memory setting is contained in a file called razorsql.bat located in the RazorSQL installation directory. In this file, there is a line containing the text -Xmx384M or -Xmx256M depending on the version of RazorSQL you are using. Increase the number before the M, which stands for MegaBytes, to increase the memory. To take advantage of the change, RazorSQL must be launched by double-clicking razorsql.bat. For Mac OS X machines, right-click on the RazorSQL application file and select "View Package Contents". Edit the Info.plist file. In this file, there is a line that contains either -Xms16m -Xmx256m or -Xms16m -Xmx384m depending on the version of RazorSQL you are using. Increase the 256 or 384 number to increase the memory. For Linux / Unix machines, edit the razorsql.sh shell script. Increase the number after the -Xmx to increase the available memory for RazorSQL.

How to save a query using RazorSQL.

There are a couple of ways to save the queries depending on how they were executed. For individual queries, the easiest way to save the query is to press the "Save Query" button located on the query results toolbar or the "Save Query" option located in the right-click menu of the query results tab. You will then be prompted for where to save the query to on your file system. If you typed the query into the sql editor, you can do a File -> Save or File -> Save As to save the editor contents to a file on your computer. If you did not execute the query from the editor, but used the navigator or query builder to execute the query, you can click on the "view query" icon in the query results toolbar or right click on "Query 1" and select "View Query" to see the query that was executed. You can then do a control-A / command-A and control-C / command-C to copy the query to your clipboard. Also, all queries you execute are stored and can be viewed by selecting Connections -> View SQL History or Connections -> View Query Log. The SQL History by default stores 20,000 lines of history. The query log stores the history for the current connection.

How to launch RazorSQL in 64-bit mode on Mac OS X

RazorSQL ships with a 32-bit launcher for Mac OS X. This launcher is compatible with both 32-bit and 64-bit Macs. However, RazorSQL will be launched in 32-bit mode even if the machine is 64-bit.

The main advantage of launching RazorSQL in 64-bit mode as opposed to 32-bit mode is the maximum amount of memory that can be addressed by RazorSQL is greater in 64-bit mode.

To change the RazorSQL launcher to the 64-bit launcher, use the following instructions:

Open up a terminal window and execute the following commands: sudo mv /Applications/RazorSQL.app/Contents/MacOS/razorsql /Applications/RazorSQL.app/Contents/MacOS/razorsql32 sudo cp /System/Library/Frameworks/JavaVM.framework/Resources/MacOS/JavaApplicationStub /Applications/RazorSQL.app/Contents/MacOS/razorsql

How to launch RazorSQL in read-only mode on Windows

RazorSQL ships with an exe file on Windows called razorsql_readonly.exe. This file is located in the RazorSQL installation directory. To launch RazorSQL in read-only mode, either launch this file by double-clicking it, or rename the existing razorsql.exe to something else, and rename razorsql_readonly.exe to razorsql.exe and launch via the normal RazorSQL shortcuts.

How to launch RazorSQL without acclerated graphics

On a small number of systems, RazorSQL's use of acclerated graphics may cause problems ranging from flickering windows to instability or crashing. RazorSQL ships with special files for Mac OS X, Windows, and Linux that allow RazorSQL to be launched with graphic acceleration turned off.

Windows: Launch RazorSQL via the razorsql_no3d.exe file located in the RazorSQL installation directory, or rename the existing razorsql.exe file to something else and rename razorsql_no3d.exe to razorsql.exe and launch RazorSQL via the normal shortcuts.

Mac OS X: RazorSQL ships with a custom plist file called Info.plist_no3d. This file is in the RazorSQL.app/Contents/Info.plist_no3d location. To launch RazorSQL without accelerated graphics, rename the existing Info.plist file to Info.plist_normal and rename Info.plist_no3d to Info.plist. You may need to copy the entire RazorSQL.app directory and launch from the copied RazorSQL.app to get the operating system to recognize the changed Info.plist.

Linux: RazorSQL ships with a razorsql_no3d.sh script. Launch RazorSQL via this script to turn off accelerated graphics.